Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
Allgemein / General
Ankündigungen und allgemeine Diskussionen rund um den PiLogger
Announcements and general discussions related to the PiLogger
  • Seite:
  • 1
  • 2

THEMA: PiLogger Web-Monitor Version 0.9 im Access-Point-Betrieb

PiLogger Web-Monitor Version 0.9 im Access-Point-Betrieb 8 Monate 2 Wochen her #1

  • crisu1205
  • crisu1205s Avatar Autor
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Beiträge: 13
  • Dank erhalten: 0
Wurde durch das Update auch die Stabilität verbessert? Ich habe seit kurzem die Version 0.8 installiert und leider funktioniert das Web-Interface nicht immer. Teilweise hilft mir ein Neustart. Ich habe einen Raspberry Pi Zero mit raspbian-buster-full und alles läuft auch die Pi-Logger Applikation, nur das Web-Interface will nicht immer. Wie kann ich prüfen, ob der Webserver korrekt funktioniert oder woran es liegt?
Eventuell ist der Zero damit auch überfordert...
Danke für die Info im voraus

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Raspberry Pi Zero läuft als Access Point (ohne Router)
PiLogger 1v2
2020-02-13-raspbian-buster-full
PiLogger WebMonitor 0.8 beta
Gehäuse mit 4 Befestigungslaschen

PiLogger Web-Monitor Version 0.9 im Access-Point-Betrieb 8 Monate 2 Wochen her #2

  • PiLo-Heinz
  • PiLo-Heinzs Avatar
  • Offline
  • Moderator
  • Moderator
  • Beiträge: 37
  • Dank erhalten: 10
Hallo crisu1205,

willkommen im Forum !
Von einem instabilen Web-Interface ist mir nichts bekannt.
Wenn der Browser meldet, das die Seite nicht erreichbar ist, liegt es meistens an einer schwachen WLAN Verbindung. Vor der Nicht-Erreichbarkeit merkt man eine schwache WLAN Verbindung auch an einer niedrigen Geschwindigkeit beim Herunterladen der Messdaten für die Diagramm-Anzeige.
Beim Zero-W hilft es die Antenne (befindet mittig an einer Längskante der Platine) in Richtung des Partners (meist der Router) zeigen zu lassen.
Allerdings habe ich keine Erfahrung damit, dass der Raspberry als Access Point arbeitet :(
Das Daten-Log ist soweit ok ? Gibt es Hinweise auf einen Neustart im PiLo-Fehler-Log ?
Wahrscheinlich gibt es für den WLAN Access Point auch ein Log, wo man die Client-Anmeldung sehen können müsste...nur kann ich nicht sagen wo (s.o.). Wenn Du mir sagst wo ich mehr zum Access Point Betrieb finde, könnte das mal testen.

Gruß, PiLo-Heinz
Folgende Benutzer bedankten sich: crisu1205

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Nichts ist unmöglich :-)

PiLogger Web-Monitor Version 0.9 im Access-Point-Betrieb 8 Monate 2 Wochen her #3

  • crisu1205
  • crisu1205s Avatar Autor
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Beiträge: 13
  • Dank erhalten: 0
Hallo PiLo-Heinz,
danke für Deine rasche Antwort. Die Info zum Access Point habe ich von www.elektronik-kompendium.de/sites/raspberry-pi/2002171.htm
Der funktioniert gut und auch der Empfang reicht für ca. 10 Meter im Umkreis. Ich kann auch per SSH bzw. VNC auf den Raspberry zugreifen, nur die Web-Oberfläche mag hie und da nicht. Da ich an dem Standort weder Internet noch einen Router habe, habe ich mich für die Access Point Variante entschieden.
Der Datenlog funktioniert auch, nur kann ich jetzt nicht die Daten downloaden, da ich nicht auf die Oberfläche komme. Wie funktioniert das mit dem PiLo-Fehler-Log?

Grüße
crisu1205

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Raspberry Pi Zero läuft als Access Point (ohne Router)
PiLogger 1v2
2020-02-13-raspbian-buster-full
PiLogger WebMonitor 0.8 beta
Gehäuse mit 4 Befestigungslaschen

PiLogger Web-Monitor Version 0.9 im Access-Point-Betrieb 8 Monate 2 Wochen her #4

  • PiLo-Heinz
  • PiLo-Heinzs Avatar
  • Offline
  • Moderator
  • Moderator
  • Beiträge: 37
  • Dank erhalten: 10
Hallo crisu1205 nochmal,

sehe gerade : Raspbian Full - das heisst im Desktop-Betrieb. Deshalb auch PiLogger 1v2 ?
Ok, das ist eine reine Python Desktop-Applikation, die gestartet werden muss und dann den PiLogger als Sensor benutzt.
Wenn Du nun den WebMonitor obendrauf installierst, wird bei jedem Neustart der WebMonitor automatisch gestartet. Das ist ein unabhängiges Python Programm (mit WebServer), das dann auch den PiLogger als Sensor ansprichst. Laufen jetzt beide, loggen auch beide und versuchen konkurrierend auf den PiLogger zuzugreifen - vielleicht kommen die Probleme daher ?

Gruß, PiLo-Heinz

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Nichts ist unmöglich :-)

PiLogger Web-Monitor Version 0.9 im Access-Point-Betrieb 8 Monate 2 Wochen her #5

  • PiLo-Heinz
  • PiLo-Heinzs Avatar
  • Offline
  • Moderator
  • Moderator
  • Beiträge: 37
  • Dank erhalten: 10
Hallo crisu1205,
Unsere letzten Beiträge haben sich gekreuzt, deshalb hier der Nachtrag:
Der WebMonitor legt im Verzeichnis /home/pi , wo auch PiLogger-bottle.py liegt, die Datei PiLo-Error.log an.
Dabei fällt mir auf, dass seit einiger Zeit der WebMonitor auf eine gültige NTP Zeit beim Starten wartet - ohne Router dürfte das schwierig sein :-(
Versuch doch mal in der Datei PiLogger-bottle.py (0v9) die Zeilen 342-345 auszukommentieren (# an den Zeilenanfang).
In der Version 0v8 sind es die Zeilen 330-333.

Gruß, PiLo-Heinz

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Nichts ist unmöglich :-)
Letzte Änderung: von PiLo-Heinz.

PiLogger Web-Monitor Version 0.9 im Access-Point-Betrieb 8 Monate 2 Wochen her #6

  • crisu1205
  • crisu1205s Avatar Autor
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Beiträge: 13
  • Dank erhalten: 0
Danke,das probiere ich aus und melde mich dann wieder.

Liebe Grüße
crisu1205

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Raspberry Pi Zero läuft als Access Point (ohne Router)
PiLogger 1v2
2020-02-13-raspbian-buster-full
PiLogger WebMonitor 0.8 beta
Gehäuse mit 4 Befestigungslaschen
  • Seite:
  • 1
  • 2
Ladezeit der Seite: 0.174 Sekunden