Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
Projekte / Projects
  • Seite:
  • 1
  • 2

THEMA: Windsensor richtig konfigurieren.

Windsensor richtig konfigurieren. 3 Wochen 5 Tage her #7

  • PeterS
  • PeterSs Avatar Autor
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Beiträge: 7
  • Dank erhalten: 1
Hi Habe jetzt den Eltako Ws im Betrieb. Dieser funktioniert sofort. Wie stelle ich jetzt die richtigen Werte ein? Gibt es da richtwerte?

Dann habe ich weitere Fragen.... Das Diagrammbild der Windgeschwindigkeit aktualisiert sich nicht. Gibt es hier eine Möglichkeit ein Live-Diagramm anzuzeigen? Das würde mir sehr helfen.

Die Livewerte sind letztlich nur auf den Windsensor interessant. Kann ich die anderen ausblenden?

Und zu guter letzt....
Ich baue mir ein mobile Büro in einem Crafter. Hier habe ich einen Wechselrichter und Versorgerbatterien. Kann ich den Strommesser in den Live-Werten hierzu nutzen? Oder würde ich damit den Logger grillen?

Gruß Peter

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Windsensor richtig konfigurieren. 3 Wochen 5 Tage her #8

  • PiLo-Heinz
  • PiLo-Heinzs Avatar
  • Offline
  • Moderator
  • Moderator
  • Beiträge: 42
  • Dank erhalten: 11
Hallo Peter,
schön zu hören, dass das mit dem Windsensor jetzt klappt !
Um eine schnelle Windmessung zu machen benutze ich diese Einstellungen:


Die Werte in "Einstellungen 1" ergeben eine schnelle Messfolge, wobei durch den "Pulszähl Zeitfaktor" die Messzeit für die Windmessung auf 3 Sekunden verlängert wird (Ist für Wind immer noch sehr kurz).
In "Einstellungen 2" wird nun allgemein ein Log-Intervall von 6 Sekunden definiert.
Dadurch wird alle 6 Sekunden eine Messwert-Zeile im Logfile geschrieben.
Die Daten im Logfile sind es auch, die in den Diagrammen dargestellt werden. Wenn Du also bisher ein recht langes Log-Intervall hattest, dann tut sich im Diagramm immer nur etwas, wenn neue Messpunkte hinzu gekommen sind.
Nach einer Konfigurationsänderung ist es sinnvoll die Diagramme neu starten zu lassen. Das machst Du indem Du mit einigen Sekunden Abstand zweimal auf "Split Log jetzt" drückst. Dadurch wird jedesmal eine neue Log-Datei begonnen. Die Anzeige-Daten werden immer als Kopie der letzten 2 Log-Dateien gehalten - deshalb der zweite Split. Dann sind die Diagrammdaten leer.

Um nur die Windwerte angezeigt zu bekommen müsstest Du die HTML Dateien ändern :(
(Für Live-Monitor Darstellung die Datei index.html im Verzeichnis 'templates')

Der Messbereich der Strommessung geht bis maximal +/-15A. Das sind bei 14V etwa 210 Watt. Wenn Du nicht mehr verbrauchst geht das....
Der PiLogger ist da mehr für das Solar-Panel dazu ausgelegt :)

Viel Erfolg !
Gruß, PiLo-Heinz
Anhang:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Nichts ist unmöglich :-)

Windsensor richtig konfigurieren. 3 Wochen 5 Tage her #9

  • PeterS
  • PeterSs Avatar Autor
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Beiträge: 7
  • Dank erhalten: 1
Danke für die ausführliche Beschreibung. Haben jetzt natürlich gerade Windstille :-)
Das mit der Strommessung lasse ich dann mal. Zumindest bis ich die Zwei Panele auf dem Dach habe ;-)

Das die geschriebenen Meßwerte dann im Diagramm angezeigt werden, klingt ebenfalls logisch. Aber hier ist das Ding. Wenn ich das Diagramm aufrufe, zeigt es mir nur die Werte bis zu dem Zeitpunkt an, welcher gerade ist. Die Zeitleiste bewegt sich nicht weiter. Idealerweise müsste sie sich automatisch in der Zeit weiterbewegen, mit jeder Messung. Dann hätte man ein "Live-Diagramm" welches ständig weiter wandert.
Somit neben dem jeweils aktuellen Wert, auch alle der eingestellten Zeitspanne als Vergleich. Man könnte dann Tendenzen erkennen ohne immer hin und her zu schalten.
Ist das machbar?
Was die HTML angeht.... ok

Gruß Peter

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Windsensor richtig konfigurieren. 3 Wochen 4 Tage her #10

  • PiLo-Heinz
  • PiLo-Heinzs Avatar
  • Offline
  • Moderator
  • Moderator
  • Beiträge: 42
  • Dank erhalten: 11
Hallo Peter,
ok - ein live rollendes Diagramm ist zur Zeit nicht implementiert.
Was die verwendete Diagrammbibliothek 'dygraphs' angeht, wäre das prinzipiell möglich.
Das würde aber eine völlig andere Art der client/server Kommunikation erfordern (eventuell mit SSE [server sent events]).
Ich geb das mal als Verbesserungswunsch weiter.
Zur Zeit liegt die 'Datenbank' in Form der csv-Datei auf dem Server (Raspi) und wird beim Aufruf der Diagrammseite einmal komplett übertragen.
Ein rollendes Diagramm würde mindestens eine kleine temporäre Datenbank beim client (Browser auf dem abrufenden Gerät) erfordern.
Wenn Du oder geneigte Leser das gerne als Projekt aufgreifen wollen: nur zu ! Die WebMonitor Software ist freie open source Software.
Ich unterstütze gerne so gut ich kann.

Gruß, PiLo-Heinz

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Nichts ist unmöglich :-)

Windsensor richtig konfigurieren. 2 Wochen 6 Tage her #11

  • PeterS
  • PeterSs Avatar Autor
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Beiträge: 7
  • Dank erhalten: 1
Ich bin da der falsche, um das zu programmieren.. Aber toll wäre das schon. Muss ja nicht rollen, reicht ja wenn es einen Punkt weiter springt, sobald ein Eintrag aufgezeichnet wird. Quasi ein wieder holter Abruf. Aber da kenne ich mich weniger aus.

PS: Den ersten scharfen Einsatz hat das System jetzt hinter sich. Konnte auf einem Mastträger auf meinem Auto die Windgeschwindigkeit aufzeichnen. Wichtig für die Starts der Drohnen....

Danke
Folgende Benutzer bedankten sich: PiLo-Heinz

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1
  • 2
Ladezeit der Seite: 0.140 Sekunden